Reply

Samsung Galaxy S2 - calls go straight to voice mail

Occasional Poster
masher
Posts: 26
Registered: ‎19-01-2012

Samsung Galaxy S2 - calls go straight to voice mail

by Occasional Poster
Message 1 of 40 (27,620 Views)

I just got a new Samsung Galaxy S2. I've just found out that all incoming calls are going straight to voice mail. I am able to make calls, send messages, and use data, but I am unable to recieve calls.

 

I've just discovered that a reboot solves it, and am currently waiting to see how long it takes for it to stop working again.

 

 

Does anyone have any ideas on how to fix it up / diagnose the root cause?

 

 

Matthew

Please use plain text.
Problem Solver
itsmoe
Posts: 893
Registered: ‎05-01-2012

Re: Samsung Galaxy S2 - calls go straight to voice mail

by Problem Solver
Message 2 of 40 (27,555 Views)

Hey mate,

 

Try follow these steps, maybe you have set up call forwarding by accident.

 

go to setting and than call settings and than call forward
make sure always forward is disabled.

 

The above should work, if not try give Vodafone a call on 1555 and speak to the technical team as they might has switched call divert on for you by accident. (I doubt it, just try step one)

 

Cheers and let me know how you go :smileyhappy:

itsmoe,
One Kudos(star) a day keeps the doctor away. :smileywink:

If we assisted with your query, please click the "Accept As Solution" button.
Please use plain text.
Occasional Poster
masher
Posts: 26
Registered: ‎19-01-2012

Re: Samsung Galaxy S2 - calls go straight to voice mail

by Occasional Poster
Message 3 of 40 (27,552 Views)

I was on the phone to Vodafone when they had me reboot it.

 

I just checked the call forwarding, and it is set to "Disable".

 

I'm currently going through all of my apps and running each of them to see if any of them upsets my phone.

Please use plain text.
Problem Solver
itsmoe
Posts: 893
Registered: ‎05-01-2012

Re: Samsung Galaxy S2 - calls go straight to voice mail

by Problem Solver
Message 4 of 40 (27,550 Views)

Hey mate,

 

Try the below instruction:

 

Disabling Diversions


1. Press Menu
2. Tap Settings
3. Tap Call
4. Tap Call Forwarding
5. Tap Voice Call (device will then update)
6. Tap one of the following diversion conditions to change:

  •     Always Forward (Unconditional; will automatically go to desired number)
  •     Forward When Busy (Conditional; will forward when 'busy or ignore' is selected)
  •     Forward When Unanswered (Conditional; will forward when phone rings out)
  •     Forward When Unreachable (Conditional; will go to desired number when phone is switched off / outside of a serviceable location)

7. Tap Disable
8. Press the Home button to exit


Note: These steps are also applicable to other Android phones related to Samsung Galaxy S II

 

Let me know how you mate.

itsmoe,
One Kudos(star) a day keeps the doctor away. :smileywink:

If we assisted with your query, please click the "Accept As Solution" button.
Please use plain text.
Occasional Poster
masher
Posts: 26
Registered: ‎19-01-2012

Re: Samsung Galaxy S2 - calls go straight to voice mail

[ Edited ]
by Occasional Poster
Message 5 of 40 (27,548 Views)

I've already done as above...

Please use plain text.
Problem Solver
itsmoe
Posts: 893
Registered: ‎05-01-2012

Re: Samsung Galaxy S2 - calls go straight to voice mail

by Problem Solver
Message 6 of 40 (27,540 Views)

it seems like you have installed an app which is tempering with your settings.

 

Best option is to back up all your data and give it a factory re-set. If the issue presist, then you should take your phone back to repairs.

 

You have 30 days to swap your handset if it is faulty, and as it seems you should be eligible for that service.

 

Cheers mate and sorry I couldn't help much.

 

Try this link below though:

http://vodafone.custhelp.com/app/answers/detail/a_id/2033/~/how-do-i-turn-off-my-voicemail%3F

itsmoe,
One Kudos(star) a day keeps the doctor away. :smileywink:

If we assisted with your query, please click the "Accept As Solution" button.
Please use plain text.
Occasional Poster
masher
Posts: 26
Registered: ‎19-01-2012

Re: Samsung Galaxy S2 - calls go straight to voice mail

by Occasional Poster
Message 7 of 40 (27,525 Views)

Played with it quite a bit last night, running different apps and the like, and it still worked (as far as I could tell).

 

Put it on charge overnight and when I got up this morning, it had stopped working.

 

"Always forward" was disabled, and the other forwards were set to the default voice mail number.

 

Next stop: when it stops working, I may change the forwarding numbers to see whether it thinks it's unreachable, busy or unanswered...

Please use plain text.
Problem Solver
Grumpyoldgreek
Posts: 204
Registered: ‎28-02-2011

Re: Samsung Galaxy S2 - calls go straight to voice mail

by Problem Solver
Message 8 of 40 (27,521 Views)

Hi Masher, fast way to fix diall 1213 from your phone first. this will ensure there are no diversions at all, then dial 1211

 

this will setup diversions to voicemail on the network, via phone settings may not be accurate.

 

1211 sets up diversion to voicemail on No answer, Busy, or out of range.

 

Info is here - http://vodafone.custhelp.com/app/answers/detail/a_id/14/related/1/session/L2F2LzEvdGltZS8xMzI3MDEzMT...

 

 

Please use plain text.
Occasional Poster
masher
Posts: 26
Registered: ‎19-01-2012

Re: Samsung Galaxy S2 - calls go straight to voice mail

by Occasional Poster
Message 9 of 40 (27,517 Views)

Ta for that!

 

I also tried out the myvodafone, and it is instantaneous! Who would have thunk it?

Please use plain text.
Problem Solver
itsmoe
Posts: 893
Registered: ‎05-01-2012

Re: Samsung Galaxy S2 - calls go straight to voice mail

by Problem Solver
Message 10 of 40 (27,507 Views)

This is really weird, as I've never came across an issue like this before, most of my previous phones were nokia so they were straight forward, few clicks and call divert is off for ever!

 

I think you best option once again is to back up your stuff and give it a factory reset.

 

Cheers mate.

itsmoe,
One Kudos(star) a day keeps the doctor away. :smileywink:

If we assisted with your query, please click the "Accept As Solution" button.
Please use plain text.
Stats
  • 39 Replies
  • 2y ago
  • 27,621 Views
  • 0 Kudos
  • 5 Contributors
Announcements
GALAXY S5 - Live blog tonight